NetBSD/xen Howto

BSD daemon

Introduction

Xen is a virtual machine monitor for x86 hardware (runs only on i686-class CPUs), which supports running multiple guests operating systems on a single machine. Guest OSes (also called “domains”) require a modified kernel which supports Xen hypercalls in replacement to access to the physical hardware. At boot, the xen kernel is loaded (via grub) along with the guest kernel for the first domain (called domain0). domain0 has privileges to access the physical hardware (PCI and ISA devices), administrate other domains and provide virtual devices (disks and network) to other domains. For more details, see http://www.cl.cam.ac.uk/Research/SRG/netos/xen/.

NetBSD can be used for both domain0 and other, unprivileged domains. (In fact there can be multiple privileged domains accessing different parts of the hardware, all providing virtual devices to unprivileged domains. We will only talk about the case of only one privileged domain, domain0). domain0 will see physical devices much like a regular i386 kernel, and will own the physical console (VGA or serial). Unprivileged domains will only see a character-only virtual console, virtual disks (xbd) and virtual network interfaces (xennet) provided by a privileged domain (usually domain0). xbd devices are connected to a physical block device (i.e. a partition of a disk, raid, ccd, ... device) in the privileged domain. xennet devices are connected to virtual devices in the privileged domain, named xvif<domain number>.<if number for this domain> (e.g. xvif1.0). Both xennet and xvif devices are seen as regular Ethernet devices (they can be seen as a crossover cable between 2 PCs) and can be assigned addresses (and be routed or NATed, filtered using IPF, etc ...) or be added as part of a bridge.


Installing NetBSD as domain0

First do a NetBSD/i386 installation of the 3.0 release (or newer) as you usually do on i386 hardware. The i386 binary release is available from ftp://ftp.NetBSD.org/pub/NetBSD/NetBSD-3.0/i386/. Binary snapshots for current and the netbsd-3 branches are available from ftp://ftp.NetBSD.org/pub/NetBSD/NetBSD-daily/. When partitioning the disk, keep in mind that you'll probably want to provide virtual disks to other domains, to reserve some partitions for these virtual domains. Alternatively, you can create large files in the filesystem, map them to vnd(4) devices and export theses vnd devices to other domains.

Next step is to install the sysutils/grub and sysutils/xentools20 packages. grub is needed to load the xen and domain0 kernels; xentools20 contains the utilities to control xen from domain0.

Next you need the Xen 2.0 kernel itself. You can get one from the binaries provided on http://www.cl.cam.ac.uk/Research/SRG/netos/xen/downloads.html (get the xen-2.0.x-install.tgz tarball) or install it via pkgsrc (sysutils/xenkernel20). The file you're looking for is xen.gz. Copy it to your root filesystem.

You'll then need a NetBSD/Xen kernel for domain0 on your root file system. The XEN0 kernel provided as part of the i386 binaries is suitable for this, but you may want to customise it. Keep your NetBSD/i386 kernel around, it can be useful for recovery. Note: make sure the kernel has support for KERNFS and /kern is already mounted.

Next you need to install Grub to load the xen.gz kernel, and the NetBSD domain0 kernel as a module. In the grub config you'll also specify the memory allocated to domain0, the console to use, etc ...

Here is a self-documented /grub/menu.lst file:

#Grub config file for NetBSD/xen. Copy as /grub/menu.lst and run
# grub-install /dev/rwd0d (assuming your boot device is wd0).
#
# The default entry to load will be the first one
default=0
# boot after 10s the default entry if the user didn't hit keyboard
timeout=10
# Configure serial port to use as console. Ignore if you'll use VGA only
serial --unit=0 --speed=115200 --word=8 --parity=no --stop=1
# Let the user select which console to use (serial or VGA), default
# to serial after 10s
terminal --timeout=10 serial console
# An entry for NetBSD/xen, using /netbsd as the domain0 kernel, and serial
# console. Domain0 will have 64MB RAM allocated.
# Assume NetBSD is installed in the first MBR partition.
title Xen 2.0 / NetBSD (hda0, serial)
  root(hd0,0)
  kernel (hd0,a)/xen.gz dom0_mem=65536 com1=115200,8n1
  module (hd0,a)/netbsd root=/dev/hda1 ro console=ttyS0 
# Same as above, but using VGA console
# We can use console=tty0 (Linux syntax) or console=pc (NetBSD syntax)
title Xen 2.0 / NetBSD (hda0, vga)
  root(hd0,0)
  kernel (hd0,a)/xen.gz dom0_mem=65536 
  module (hd0,a)/netbsd root=/dev/hda1 ro console=tty0 
# NetBSD/xen using a backup domain0 kernel (in case you installed a
# nonworking kernel as /netbsd
title Xen 2.0 / NetBSD (hda0, backup, serial)
  root(hd0,0)
  kernel (hd0,a)/xen.gz dom0_mem=65536 com1=115200,8n1
  module (hd0,a)/netbsd.backup root=/dev/hda1 ro console=ttyS0
title Xen 2.0 / NetBSD (hda0, backup, VGA)
  root(hd0,0)
  kernel (hd0,a)/xen.gz dom0_mem=65536
  module (hd0,a)/netbsd.backup root=/dev/hda1 ro console=tty0
#Load a regular NetBSD/i386 kernel. Can be useful if you end up with a
#nonworking /xen.gz
title NetBSD 2.0
  root (hd0,a)
  kernel --type=netbsd /netbsd-GENERIC
#Load the NetBSD bootloader, letting it load the NetBSD/i386 kernel.
#May be better than the above, as grub can't pass all required infos
#to the NetBSD/i386 kernel (e.g. console, root device, ...)
title NetBSD chain
  root        (hd0,0)
  chainloader +1
## end of grub config file.
      

Creating unprivileged domains

Once you have domain0 running, you need to start the xen tool daemon (/usr/pkg/share/examples/rc.d/xend start). Make sure that /dev/xencons and /dev/xenevt exist before starting xend, you can create them with this command:

# cd /dev && sh MAKEDEV xen

xend will write logs to /var/log/xend.log and /var/log/xend-debug.log. You can then control xen with the xm tool. 'xm list' you show something like:

# xm list
Name              Id  Mem(MB)  CPU  State  Time(s)  Console
Domain-0           0       64    0  r----     58.1        

Note that all communications between xend and xm happen via a TCP socket, and xend listen to *.8000, *.8001 and *.8002. Anyone will be able to control xen via these ports. I strongly suggest that you filter these ports on your domain0 (using IPF or PF) allowing access only from 127.0.0.1, and restrict users able to log in to domain0.

'xm create' allows you to create a new domain. It use a config file for its parameters in PKG_SYSCONFDIR (by default /usr/pkg/etc/xen/. On creation, a kernel has to be specified, which will be executed in the new domain (this kernel is in the domain0 file system, not on the new domain virtual disk; but please note, you should install just the same kernel into domainU as /netbsd in order to make your system tools, like savecore(8), workable). A suitable kernel is provided as part of the i386 binary sets, XENU.

Here is an /usr/pkg/etc/xen/nbsd example config file:

#  -*- mode: python; -*-
#============================================================================
# Python defaults setup for 'xm create'.
# Edit this file to reflect the configuration of your system.
#============================================================================

#----------------------------------------------------------------------------
# Kernel image file. This kernel will be loaded in the new domain.
kernel = "/home/bouyer/netbsd-XENU"
#kernel = "/home/bouyer/netbsd-INSTALL_XENU"

# Memory allocation (in megabytes) for the new domain.
memory = 128

# A handy name for your new domain. This will appear in 'xm list',
# and you can use this as parameters for xm in place of the domain
# number. All domains must have different names.
#
name = "nbsd"

# Which CPU to start domain on (only relevant for SMP hardware).  CPUs
# numbered starting from ``0''.
#
cpu = -1   # leave to Xen to pick

#----------------------------------------------------------------------------
# Define network interfaces for the new domain.

# Number of network interfaces (must be at least 1). Default is 1.
nics = 1

# Define MAC and/or bridge for the network interfaces.
#
# The MAC address specified in ``mac'' is the one used for the interface
# in the new domain. The interface in domain0 will use this address XOR'd
# with 00:00:00:01:00:00 (i.e. aa:00:00:51:02:f0 in our example). Random
# MACs are assigned if not given.
#
# ``bridge'' is a required parameter, which will be passed to the
# vif-script called by xend(8) when a new domain is created to configure
# the new xvif interface in domain0.
#
# In this example, the xvif is added to bridge0, which should have been
# set up prior to the new domain being created -- either in the
# ``network'' script or using a /etc/ifconfig.bridge0 file.
#
vif = [ 'mac=aa:00:00:50:02:f0, bridge=bridge0' ]

#----------------------------------------------------------------------------
# Define the disk devices you want the domain to have access to, and
# what you want them accessible as.
#
# Each disk entry is of the form:
#
#	phy:DEV,VDEV,MODE
#
# where DEV is the device, VDEV is the device name the domain will see,
# and MODE is r for read-only, w for read-write.  You can also create
# file-backed domains using disk entries of the form:
#
#	file:PATH,VDEV,MODE
#
# where PATH is the path to the file used as the virtual disk, and VDEV
# and MODE have the same meaning as for ``phy'' devices.
#
# VDEV doesn't really matter for a NetBSD guest OS, but it does for Linux.
# Worse, the device has to exists in /dev/ of domain0, because xm will
# try to stat() it. This means that in order to load a Linux guest OS
# from a NetBSD domain0, you'll have to create /dev/hda1, /dev/hda2, ...
# on domain0, with the major/minor from Linux :(

disk = [ 'phy:/dev/wd0e,wd0d,w' ]
#disk = [ 'file:/var/xen/nbsd-disk,wd0d,w' ]

#----------------------------------------------------------------------------
# Set the kernel command line for the new domain.

# Set root device. This one does matter for NetBSD
root = "/dev/wd0d"
# extra parameters passed to the kernel
#extra = ""

#----------------------------------------------------------------------------
# Set according to whether you want the domain  restarted when it exits.
# The default is False.
#autorestart = True

# end of nbsd config file ====================================================

When a new domain is created, xen calls the /usr/pkg/etc/xen/vif-bridge script for each virtual network interface created in domain0. This can be used to configure automatically the xvif?.? interfaces in domain0. In our example, these will be bridged with the bridge0 device in domain0. But the bridge has to exists first. You can just create /etc/ifconfig.bridge0 file with:

create
!brconfig $int add ex0 up

(replace ex0 with the name of your physical interface). Then bridge0 will be created on boot. See the man page bridge(4) for details.

So, here is a suitable /usr/pkg/etc/xen/vif-bridge for xvif?.? (a working vif-bridge is also provided with xentools20) configuring:

#!/bin/sh
#============================================================================
# $NetBSD: vif-bridge-nbsd,v 1.3 2005/11/08 00:47:35 jlam Exp $
#
# /usr/pkg/etc/xen/vif-bridge
#
# Script for configuring a vif in bridged mode with a dom0 interface.
# The xend(8) daemon calls a vif script when bringing a vif up or down.
# The script name to use is defined in /usr/pkg/etc/xen/xend-config.sxp
# in the ``vif-script'' field.
#
# Usage: vif-bridge up|down [var=value ...]
#
# Actions:
#    up		Adds the vif interface to the bridge.
#    down	Removes the vif interface from the bridge.
#
# Variables:
#    domain	name of the domain the interface is on (required).
#    vifq	vif interface name (required).
#    mac	vif MAC address (required).
#    bridge	bridge to add the vif to (required).
#
# Example invocation:
#
# vif-bridge up domain=VM1 vif=xvif1.0 mac="ee:14:01:d0:ec:af" bridge=bridge0
#
#============================================================================

# Exit if anything goes wrong
set -e 

echo "vif-bridge $*"

# Operation name.
OP=$1; shift

# Pull variables in args into environment
for arg ; do export "${arg}" ; done

# Required parameters. Fail if not set.
domain=${domain:?}
vif=${vif:?}
mac=${mac:?}
bridge=${bridge:?}

# Optional parameters. Set defaults.
ip=${ip:-''}   # default to null (do nothing)

# Are we going up or down?
case $OP in
up)	brcmd='add' ;;
down)	brcmd='delete' ;;
*)
	echo 'Invalid command: ' $OP
	echo 'Valid commands are: up, down'
	exit 1
	;;
esac

# Don't do anything if the bridge is "null".
if [ "${bridge}" = "null" ] ; then
	exit
fi

# Don't do anything if the bridge doesn't exist.
if ! ifconfig -l | grep "${bridge}" >/dev/null; then
	exit
fi

# Add/remove vif to/from bridge.
ifconfig x${vif} $OP
brconfig ${bridge} ${brcmd} x${vif}

Now, running

xm create -c /usr/pkg/etc/xen/nbsd

(note: -c cause xm to connect to the domain's console once created) should create a domain and load a NetBSD kernel in it. But the kernel will try to find its root file system on xbd0 (i.e. wd0e) which doesn't exists yet. wd0e will be seen as a disk device in the new domain, so it will be 'sub-partitioned'. We could attach a ccd to wd0e and partition it, newfs and extract the NetBSD/i386 tarballs here, but there's an easier way: load the netbsd-INSTALL_XENU kernel provided in the NetBSD/i386 binary sets. Like others i386 install kernels, it contains a ramdisk with sysinst, so you can install NetBSD using sysinst on your new domain.

If you want to install NetBSD/Xen with the CDROM image, the following line should be used in the /usr/pkg/etc/xen/nbsd file:

disk = [ 'phy:/dev/cd0a,cd0a,r', 'phy:/dev/wd0e,wd0d,w' ]

After booting the domain, the option to install via CDROM may be selected, finally the device should be changed to xbd1d.

Once done, halt -p the new domain (don't reboot or halt, it would reload the INSTALL_XENU kernel even if you changed the config file), switch back to the XENU kernel in the config file, and start the new domain again. Now it should be able to use root on xbd0a and have a second, functional NetBSD/i386 system on your xen installation.

When the new domain is booting you'll see some warnings about wscons and the pseudo-terminals, these may be fixed by editing the files /etc/ttys and /etc/wscons.conf. You must disable all terminals on /etc/ttys, except console, like this:

console "/usr/libexec/getty Pc"         vt100   on secure
ttyE0   "/usr/libexec/getty Pc"         vt220   off secure
ttyE1   "/usr/libexec/getty Pc"         vt220   off secure
ttyE2   "/usr/libexec/getty Pc"         vt220   off secure
ttyE3   "/usr/libexec/getty Pc"         vt220   off secure

Finally, all screens must be commented out from /etc/wscons.conf. It is also desireable to add

powerd=YES

in rc.conf. This way, the domain will be properly shut down if 'xm shutdown -R' or 'xm shutdown -H' is used on the domain0. Your domain should be now ready to work, enjoy.

Creating Linux unprivileged domains

Creating Linux unprivileged domains isn't much different from NetBSD unprivileged domains, but there are some details to know

first, the second parameter passed to disk (the 'wd0d' in the example below)

disk = [ 'phy:/dev/wd0e,wd0d,w' ]

does matter to Linux. It wants a Linux device name here (e.g. hda1). But the xen tools will lookup this name in the domain0's /dev/ to get the device number. Fortunatly it's possible to replace this name to the device number in hex. Linux builds device numbers as: (major << 8 + minor). So, hda1 which has major 3 and minor 1 on a Linux system will have device numer 0x301. To export a partition to a Linux guest we can use:

disk = [ 'phy:/dev/wd0e,0x301,w' ]
root = "/dev/hda1 ro"

and it will appear as /dev/hda1 on the Linux system, and be used as root partition.

A virtual block device can't be partitoned in the Linux domain as it is in the NetBSD domain. This means that each partition that will be available in the Linux system have to be exported from the domain0 system. Usually at last 2 are needed (/ and swap) so in the config file you'll have something like: disk = [ 'phy:/dev/wd0e,0x301,w', 'phy:/dev/wd0f,0x302,w' ] where hda1 would be the root and hda2 swap.

To install the Linux system on the partition to be exported to the guest domain, the following method can be used: install sysutils/e2fsprogs from pkgsrc. Use mke2fs to format the partition that will be the root partition of your Linux domain, and mount it. Then copy the files from a working Linux system, make adjustments in etc (fstab, network config). It should also be possible to extract binary packages such as .rpm or .deb directly to the mounted partition, using the appropriate tool, possibly running under NetBSD's Linux emulation. Once the filesystem has been populated, umount it. If desirable, the filesystem can be converted to ext3 using tune2fs -j. It should now be possible to boot the Linux guest domain, using one of the vmlinuz-*-xenU kernels available in the Xen binary distribution.

Using PCI devices in guest domains

The hypervisor can give access to selected PCI devices to other domains than domain0. This can allow, for example, a non-privileged domain to have access to a physical network interface or disk controller, for example. However, keep in mind that giving access to a PCI device to a domain most likely will give it read/write access to the whole physical memory, as PCs don't have an IOMMU to restrict memory access to DMA-capable device. Also, it's not possible to export ISA devices to non-domain0 domains (which means that the primary VGA adapter can't be exported. A guest domain trying to access the VGA registers will panic).

Before exporting a PCI device to a guest domain, it's strongly recommended to configure the hypervisor to hide this PCI device from domain0. This is done with the physdev_dom0_hide option on the boot command line. The format is:

physdev_dom0_hide='(%02x:%02x.%1x)(%02x:%02x.%1x)...'

For example, to hide devices PCI bus 0, device 4, function 2 and PCI bus 0, device 6, function 0 and PCI bus 1, device 0, function 0 I use (note that numbers passed to physdev_dom0_hide are interpreted in hex):

physdev_dom0_hide='(00:04.2)(01:00.0)(00:06.0)'

Next thing to do is to build a domainU kernel with support for the devices you will use. Here is an example:

include         "arch/i386/conf/XENU"

# Add support for PCI busses to the XENU kernel
pci*            at hypervisor? bus ?

# Now add PCI and related devices to be used by this domain
# USB Controller and Devices

# PCI USB controllers
uhci*   at pci? dev ? function ?        # Universal Host Controller (Intel)

# USB bus support
usb*    at uhci?

# USB Hubs
uhub*   at usb?
uhub*   at uhub? port ? configuration ? interface ?

# USB Mass Storage
umass*  at uhub? port ? configuration ? interface ?
wd*     at umass?

# SCSI controllers
ahc*    at pci? dev ? function ?        # Adaptec [23]94x, aic78x0 SCSI

# SCSI bus support (for both ahc and umass)
scsibus* at scsi?

# SCSI devices
sd*     at scsibus? target ? lun ?      # SCSI disk drives
cd*     at scsibus? target ? lun ?      # SCSI CD-ROM drives

Finally, add the PCI devices to export to your domain's config file:

# export PCI devices. Numbers here can be decimal or hexadecimal
pci = [ '0,4,2','0,6,0' ]

When booting this domain, you should see, in addition to the usual xbd and xennet devices, PCI busses and the devices you exported.

Links and further information


Back to  NetBSD/xen Port Page

(contact us)   Generated from %NetBSD: howto.xml,v 1.33 2006/03/12 15:05:54 hubertf Exp %
Copyright © 1994-2006 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.
NetBSD® is a registered trademark of The NetBSD Foundation, Inc.